PAT题目分析

PAT A1019 General Parlindromic N

2019-03-17  本文已影响0人  ranerr_

A1019 General Parlindromic Numbers
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.
Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

分析:

  1. 进制转换的时候注意0的情况
#include <cstdio>
#include <vector>
using namespace std;
void DecimalToK(int d, vector<int> &dink, int k) {
  dink.clear();
  if (d == 0) {
    dink.push_back(0);
  }
  while (d != 0) {
    dink.push_back(d % k);
    d /= k;
  }
}
bool IsPalindromic(const vector<int> &dink) {
  for (vector<int>::size_type i = 0; i <= dink.size() / 2; i++) {
    if (dink[i] != dink[dink.size() - i - 1])
      return false;
  }
  return true;
}
int main() {
  int n, b;
  vector<int> nink;
  scanf("%d%d", &n, &b);
  DecimalToK(n, nink, b);
  if (IsPalindromic(nink)) {
    printf("Yes\n");
  } else {
    printf("No\n");
  }
  for (vector<int>::size_type i = nink.size() - 1; i < nink.size(); i--) {
    if (i != 0)
      printf("%d ", nink[i]);
    else
      printf("%d", nink[i]);
  }
  return 0;
}

上一篇下一篇

猜你喜欢

热点阅读