CUC-SUMMER-11-A

2017-08-18  本文已影响0人  Nioge
A - Football
POJ-3071

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input
The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output
The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1
Sample Output
2
Hint
In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.


题意:已知每两个队伍对阵的胜率,求哪只队伍最后获胜几率最高,输出这个概率

解法:概率DP,dp[k][i]表示第k轮第i支队伍的胜率,则dp[k][i]=dp[k-1][i]dp[k-1][j]a[i][j],其中j是所有在此轮i要击败的队伍

代码:

#include<iostream>
#include<cstdio>
using namespace std;
double a[150][150];
double dp[10][150];
int main()
{
    int n;
    while(scanf("%d",&n)&&n!=-1){
        for(int i=1;i<=(1<<n);i++)
            for(int j=1;j<=(1<<n);j++)
                scanf("%lf",&a[i][j]);
        for(int i=1;i<=(1<<n);i++)
            dp[0][i]=1.0;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=(1<<n);j++){
                dp[i][j]=0;
                for(int k=1;k<=(1<<n);k++)
                    if(((k-1)/(1<<i)==(j-1)/(1<<i))&&((k-1)/(1<<(i-1))!=(j-1)/(1<<(i-1))))
                        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*a[j][k];
            }
        }
        int ans=1;
        for(int i=2;i<=(1<<n);i++)
            if(dp[n][i]>dp[n][ans])
                ans=i;
        printf("%d\n",ans);
    }
}
上一篇下一篇

猜你喜欢

热点阅读