【PAT A1024】 Palindromic Number (

2018-08-08  本文已影响0人  AdmondGuo

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

给出一个整数n,是否能在k次操作下使其成为回文数,操作如下:
n+=n的逆序数;
如果能在k次内完成,输出此时的n和次数
否则输出k次时的n,和k
由于数值较大,远远超过longlong 的范围,是大整数问题。
按照算法笔记上的套路
code:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

struct bign{
    int b[1100];
    int len;
    bign(){
        memset(b,0,sizeof(b));
        len=0;
    }
};

bign change(char s[]){
    bign c;
    c.len=strlen(s);
    for(int i=0;i<c.len;i++){
        c.b[i]=s[c.len-1-i]-'0';
    }
    return c;
}

bign add(bign a,bign b){
    int carry=0;
    int temp=0;
    bign c;
    for(int i=0;i<a.len||i<b.len;i++){
        temp=a.b[i]+b.b[i]+carry;
        c.b[c.len++]=temp%10;
        carry=temp/10;
    }
    if(carry!=0)
        c.b[c.len++]=carry;
    return c;
}

bign pa(bign a){
    bign b;
    for(int i=0;i<a.len;i++){
        b.b[i]=a.b[a.len-1-i];
    }
    return b;
}
bool judge(bign a){
    int l=0,r=a.len-1;
    while(l<r){
        if(a.b[l++]!=a.b[r--])
            return false;
    }
    return true;
}
void print(bign c){
    for(int i=c.len-1;i>=0;i--){
        cout<<c.b[i];
    }
    cout<<endl;
}
int main(){
    char str[1100];
    int k=0;
    int i=0;
    scanf("%s%d",str,&k);
    bign a=change(str);
    bign b,c;
    if(judge(a)==true){
        i=0;
        c=a;
    }
    else{
        for(i=1;i<=k;i++){
            b=pa(a);
            c=add(a,b);
            if(judge(c)==true||i==k){
                break;  
            }
            else{
                memset(a.b,0,sizeof(a.b));
                a=c;
            }
        }
    }
        print(c);
        cout<<i;
    system("pause");
    return 0;
}

柳神:

#include <iostream>
#include <algorithm>
using namespace std;
string s;
void add(string t) {
    int len = s.length(), carry = 0;
    for(int i = 0; i < len; i++) {
        s[i] = s[i] + t[i] + carry - '0';
        carry = 0;
        if(s[i] > '9') {
            s[i] = s[i] - 10;
            carry = 1;
        }
    }
    if(carry) s += '1';
    reverse(s.begin(), s.end());
}
int main() {
    int cnt, i;
    cin >> s >> cnt;
    for(i = 0; i <= cnt; i++) {
        string t = s;
        reverse(t.begin(), t.end());
        if(s == t || i == cnt) break;    //回文串!
        add(t);
    }
    cout << s << endl << i;
    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读