Poj

Poj 1384 Piggy-Bank

2017-08-19  本文已影响36人  86棵梦

题目

Poj 1384 Piggy-Bank

Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

具体的内容就是一共有多种硬币,分别给出了每种硬币的重量与价格,然后根据存钱罐的重量,来判断是否可行,如果可行的话,存钱罐中最小的价值是多少。仍然是背包问题。

代码

// http://poj.org/problem?id=1384
#include <stdio.h>
#include <iostream>
#include <bitset>
#include <algorithm>
using namespace std;

struct Coin {
    int value;
    int weight;
};

Coin coinList[505];
int result[50000];

int MAX_RESULT = 50000 * 10000 + 10;

int updateResult(int maxAmount, int coinType) {
    for (int i = 0; i <= maxAmount; i++) {
        result[i] = MAX_RESULT;
    }
    
    result[0] = 0;
    for (int i = 0; i < coinType; i++) {
        int value = coinList[i].value;
        int weight = coinList[i].weight;

        for(int t = weight; t <= maxAmount; t++) {
            result[t] = min(result[t], result[t - weight] + value);
        }
    }
    return result[maxAmount];
}

int main(int argc, const char * argv[]) {
    int test, coinType, emptyWeight, fullWeight;
    scanf("%d", &test);
    for (int i = 0; i < test; i++) {
        scanf("%d %d", &emptyWeight, &fullWeight);
        scanf("%d", &coinType);
        for (int t = 0; t < coinType; t++) {
            scanf("%d %d", &coinList[t].value, &coinList[t].weight);
        }
        int result = updateResult(fullWeight - emptyWeight, coinType);
        if (MAX_RESULT == result) {
            printf("This is impossible.\n");
        } else {
            printf("The minimum amount of money in the piggy-bank is %d.\n", result);
        }
    }
}
上一篇下一篇

猜你喜欢

热点阅读