ACM 之 F - 数论

2016-08-05  本文已影响33人  Gadore千里

Description

There is a hill with n holes around. The holes are signed from 0 to n-1. rabit and the wolfrabit and the wolf

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

Sample Input

2
1 2
2 2

Sample Output

NO
YES

理解

代码部分

#include <cstdio>
using namespace std;
int m,n,t,k;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        int x,y,i;
        scanf("%d%d",&m,&n);
        x=m;y=n;
        while(x!=0)
        {
            i=y%x;
            y=x;
            x=i;
        }
        printf("%s\n",y==1?"NO":"YES");
    }
}

意见反馈 || 任何建议

联系我(新浪)
邮箱:qianlizhihao@gmail.com

上一篇 下一篇

猜你喜欢

热点阅读