2020-04-21

2020-04-21  本文已影响0人  joker_luo

1097 Deduplication on a Linked List (25分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

      
    

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

      
    

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
#include<iostream>
#include<cmath>
#include<vector>
using namespace std;
const int maxn = 100010;
typedef struct node{
    int address;
    int key;
    int next;
}node;
vector<node> ans1,ans2;
bool visit[10010]={false};//输入的数不大于10000 
int main(){
    node list[maxn];
    int first,n;
    cin>>first>>n;
    for(int i=0;i<n;i++){
        int addr,key,next;
        cin>>addr>>key>>next;
        list[addr].address = addr;
        list[addr].key = key;
        list[addr].next = next;
    }
    int begin = first;
    while(begin!=-1){
        int value = fabs(list[begin].key);
        if(!visit[value]){//判断当前节点是否重复,若不重复,加入ans1,否则ans2 
            ans1.push_back(list[begin]);
        }else{
            ans2.push_back(list[begin]);
        }
        visit[value] = 1;
        begin = list[begin].next;
    }
    for(int i=0;i<ans1.size();i++){
        if(i!=ans1.size()-1){
            printf("%05d %d %05d\n",ans1[i].address,ans1[i].key,ans1[i+1].address);
        }else{
            printf("%05d %d -1\n",ans1[i].address,ans1[i].key);
        }
    }
    for(int i=0;i<ans2.size();i++){
        if(i!=ans2.size()-1){
            printf("%05d %d %05d\n",ans2[i].address,ans2[i].key,ans2[i+1].address);
        }else{
            printf("%05d %d -1\n",ans2[i].address,ans2[i].key);
        }
    }   
    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读