pat1028
2018-10-08 本文已影响0人
hsinsDfy
1028 人口普查 (20 分)
某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。
这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。
输入格式:
输入在第一行给出正整数 N,取值在(0,105];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。
输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John
#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct People{
string name;
int year;
int month;
int date;
};
bool cmp(People a,People b){
if(a.year!=b.year)
return a.year<b.year;
else if(a.month!=b.month)
return a.month<b.month;
else return a.date<b.date;
}
int main(){
People peo;
vector<People>P;
int N;
cin>>N;
for(int i=0;i<N;++i){
cin>>peo.name;
scanf("%d/%d/%d",&peo.year,&peo.month,&peo.date);
if(peo.year>2014)
continue;
if(peo.year==2014&&peo.month>9)
continue;
if(peo.year==2014&&peo.month==9&&peo.date>6)
continue;
if(peo.year<1814)
continue;
if(peo.year==1814&&peo.month<9)
continue;
if(peo.year==1814&&peo.month==9&&peo.date<6)
continue;
else
P.push_back(peo);
}
if(!P.empty()){
sort(P.begin(),P.end(),cmp);
cout<<P.size()<<" "<<(*P.begin()).name<<" "<<(*(P.end()-1)).name;
}
else cout<<0;
system("pause");
return 0;
}