python小课——零基础入门——学习笔记Leetcode模拟面试LeetCode刷题

PTA 1092 最好吃的月饼

2021-08-19  本文已影响0人  freesan44

题目

月饼是久负盛名的中国传统糕点之一,自唐朝以来,已经发展出几百品种。

mk.jpg

若想评比出一种“最好吃”的月饼,那势必在吃货界引发一场腥风血雨…… 在这里我们用数字说话,给出全国各地各种月饼的销量,要求你从中找出销量冠军,认定为最好吃的月饼。

输入格式:

输入首先给出两个正整数 N(≤1000)和 M(≤100),分别为月饼的种类数(于是默认月饼种类从 1 到 N 编号)和参与统计的城市数量。

接下来 M 行,每行给出 N 个非负整数(均不超过 1 百万),其中第 i 个整数为第 i 种月饼的销量(块)。数字间以空格分隔。

输出格式:

在第一行中输出最大销量,第二行输出销量最大的月饼的种类编号。如果冠军不唯一,则按编号递增顺序输出并列冠军。数字间以 1 个空格分隔,行首尾不得有多余空格。

输入样例:

5 3
1001 992 0 233 6
8 0 2018 0 2008
36 18 0 1024 4

输出样例:

2018
3 5

解题思路

inputStr1 = input().split(" ")
# inputStr1 = "5 3".split(" ")
yuebinCount = int(inputStr1[0])
cityCount = int(inputStr1[1])
countList = []
# 根据月饼种类形成列表
for i in range(yuebinCount):
    countList.append(0)
# 根据逐个输入,添加到总数
for i in range(cityCount):
    yuebinCount = input().split(" ")
    # yuebinCount = "1001 992 0 233 6".split(" ")
    for (index,value) in enumerate(yuebinCount):
        countList[index] = countList[index] + int(value)
# print(countList)
maxNum = max(countList)
maxList = []
# 把最大值的index找出来
for (index, value) in enumerate(countList):
    if value == maxNum:
        maxList.append(str(index+1))
# 打印最高值
print(maxNum)
# 最高值的index打印出来
print(" ".join(maxList))
上一篇下一篇

猜你喜欢

热点阅读