HDU 2099 整除的尾数
2022-04-04 本文已影响0人
itbird01
Problem Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
Sample Input
200 40 1992 95 0 0
Sample Output
00 40 80 15
java code
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
// 用hasnextint,不然会error
while (scanner.hasNextInt()) {
int a = scanner.nextInt();
int b = scanner.nextInt();
if (a == 0 && b == 0) {
break;
}
String result = "";
for (int i = 0; i < 100; i++) {
if ((a * 100 + i) % b == 0) {
if (i < 10) {
result += "0" + i + " ";
} else {
result += i + " ";
}
}
}
result = result.substring(0, result.length() - 1);
System.out.println(result);
}
scanner.close();
}
}```