1132 Cut Integer (20 分)

2018-09-22  本文已影响0人  W杂货铺W

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​ ). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

code

#include <iostream>
#include <string>

using namespace std;

int main()
{
    int n;
    cin >> n;
    string s;
    for(int i=0;i<n;i++)
    {
        cin >> s;
        int len = s.length();
        string s1,s2;
        s1 = s.substr(0,len/2);
        s2 = s.substr(len/2);
        long a,b,c;
        a = atol(s1.c_str());
        b = atol(s2.c_str());
        c = atol(s.c_str());
        
        if(a*b=0) {
            cout << "No" << endl;
        } else if(c%(a*b)==0){
            cout << "Yes" << endl;
        } else {cout << "No" << endl;}
    }
}

note

假设:string s = "0123456789";
string sub1 = s.substr(5); //只有一个数字5表示从下标为5开始一直到结尾:sub1 = "56789"
string sub2 = s.substr(5, 3); //从下标为5开始截取长度为3位:sub2 = "567

#include <iostream>
#include <string>

int main ()
{
  std::string str="We think in generalities, but we live in details.";

  std::string str2 = str.substr (3,5);     //  "think"

  std::size_t pos = str.find("live");      // position of "live" in str

  std::string str3 = str.substr (pos);     // get from "live" to the end

  std::cout << str2 << ' ' << str3 << '\n'; // "think live in details."

  return 0;
}
上一篇 下一篇

猜你喜欢

热点阅读