1084 Broken Keyboard (two pointe

2018-09-27  本文已影响0人  virgilshi

1084 Broken Keyboard (two pointer)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

题目大意

给来个字符串,询问坏掉的key

#include <iostream>
#include <map>
using namespace std;
map<char,bool> mp;
int main(){
    string s1,s2,ans;
    cin>>s1>>s2;
    int i=0,j=0;
    while(i<s1.length() && j<s2.length()){
        if(s1[i]==s2[j]) i++,j++;
        else{
            if(mp[toupper(s1[i])]==false)
            {
                ans.push_back(toupper(s1[i]));
                mp[toupper(s1[i])]=true;
            }
            i++;
        }
    }
    while(i<s1.length()){
        if(mp[toupper(s1[i])]==false)
            {
                ans.push_back(toupper(s1[i]));
                mp[toupper(s1[i])]=true;
            }
            i++;
    }
    cout<<ans;
    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读