PAT 甲级 刷题日记|A 1091 Acute Stroke
单词积累
volume 体积
constant 不变的, 恒常的
题目
One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).
Then L slices are given. Each slice is represented by an M×N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

Output Specification:
For each case, output in a line the total volume of the stroke core.
Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
结尾无空行
Sample Output:
26
思路:
典型的搜索题目,将一般的一维二维空间扩展到三维进行搜索,只需要在扩展方向上进行改动即可。
代码
#include <bits/stdc++.h>
using namespace std;
const int maxm = 1290;
const int maxn = 130;
const int maxl = 62;
int gra[maxl][maxm][maxn];
int visit[maxl][maxm][maxn];
int dir[6][3] = {0, -1, 0, 0, 0, -1, 0, 1, 0, 0, 0, 1, 1, 0, 0, -1, 0, 0};
int m, n, l, ku;
struct node{
int i, j, k;
node(int i, int j, int k): i(i), j(j), k(k) {
}
};
int BFS(int i, int j, int k) {
int num = 0;
queue<node> mq;
mq.push(node(i, j, k));
visit[i][j][k] = 1;
while (!mq.empty()) {
node cur = mq.front();
mq.pop();
num++;
for (int i = 0; i < 6; i++) {
node now(cur.i, cur.j, cur.k);
now.i += dir[i][0];
now.j += dir[i][1];
now.k += dir[i][2];
if (now.i >= 0 && now.j >= 0 && now.k >= 0 && now.i < l && now.j < m && now.k < n && visit[now.i][now.j][now.k] == 0&& gra[now.i][now.j][now.k] == 1) {
mq.push(now);
visit[now.i][now.j][now.k] = 1;
}
}
}
return num;
}
int main() {
cin>>m>>n>>l>>ku;
for (int i = 0; i < l; i++) {
for (int j = 0; j < m; j++) {
for (int k = 0; k < n; k++) {
cin>>gra[i][j][k];
}
}
}
int ans = 0;
for (int i = 0; i < l; i++) {
for (int j = 0; j < m; j++) {
for (int k = 0; k < n; k++) {
if (visit[i][j][k] == 0 && gra[i][j][k] == 1) {
int vo = BFS(i, j, k);
if (vo >= ku) ans += vo;
}
}
}
}
cout<<ans<<endl;
}