2020-05-10

2020-05-10  本文已影响0人  joker_luo

1021 Deepest Root (25分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

      
    

Sample Output 1:

3
4
5

      
    

Sample Input 2:

5
1 3
1 4
2 5
3 4

      
    

Sample Output 2:

Error: 2 components
#include<iostream>
#include<vector>
#include<set>
using namespace std;
int n;
int maxheight = 0;
vector<vector<int>> v;
bool visit[10010];
vector<int> temp;
set<int> s;
void dfs(int node,int height){
    if(height>maxheight){
        temp.clear();
        temp.push_back(node);
        maxheight = height;
    }else if(height==maxheight){
        temp.push_back(node);
    }
    visit[node] = true;
    for(int i=0;i<v[node].size();i++){
        if(visit[v[node][i]]==false){
            dfs(v[node][i],height+1);
        }
    }
}
int main(){
    scanf("%d",&n);
    v.resize(n+1);
    int a,b;
    for(int i=0;i<n-1;++i){
        scanf("%d%d",&a,&b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    int cnt = 0;
    int e;
    for(int i=1;i<=n;i++){//节点是以1开始 
        if(visit[i]==false){
            dfs(i,1);
            if(i==1){
                if(temp.size()!=0){
                    //随意取一个使树深度最大的节点
                    //两次dfs求并
                    e = temp[0];
                }
                for(int j=0;j<temp.size();++j){
                    s.insert(temp[j]);
                }
            }
            cnt++;
        }
    }
    if(cnt>=2){
        printf("Error: %d components",cnt);
    }else{
        temp.clear();
        maxheight = 0;
        fill(visit,visit+10010,false);
        dfs(e,1);
        for(int j=0;j<temp.size();++j){
            s.insert(temp[j]);
        }
        for(auto it=s.begin();it!=s.end();++it){
            printf("%d\n",*it);
        }
    }
    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读