C++

ACM 之 Red and Black

2016-07-16  本文已影响223人  Gadore千里

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
...... 
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

理解:

相当于求联通块,这种题做过一次在遇到就会感觉简单很多.同样用到DFS.
还有需要注意的是 , 输入顺序 , 题目是把第一个输入的值当做列,第二个输入的值当做行数 .

代码部分

#include<iostream>
using namespace std;
char a[21][21];int b[21][21],m,n,sum;
void dfs(int i,int j)
{
    if(a[i][j]=='#'||i<0||i>m-1||j<0||j>n-1||b[i][j]==1||a[i][j]!='.') return ;
    b[i][j]=1;sum++;
    dfs(i+1,j);
    dfs(i-1,j);
    dfs(i,j-1);
    dfs(i,j+1);
}
int main()
{
    while(cin>>n>>m)
    {
        int x,y;
        if(m==0&&n==0)
            return 0;
        sum=0;
        for(int i=0;i<21;i++)
        {
            for(int j=0;j<21;j++)
            {
                b[i][j]=0;
            }
        }
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='@')
                {
                    x=i;y=j;a[i][j]='.';
                }
            }
        }
        dfs(x,y);
        /*for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cout<<b[i][j];
            }
            cout<<endl;
        }*/
        cout<<sum<<endl;
    }
    return 0;
}

意见反馈 || 任何建议

联系我(新浪)
邮箱:qianlizhihao@gmail.com

上一篇下一篇

猜你喜欢

热点阅读