A hard puzzle

2017-06-28  本文已影响16人  pro_ven_ce

传送门

Description

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output

For each test case, you should output the a^b's last digit number.
Sample Input
7 66
8 800

Sample Output

9
6

算最后一位数取余就好了,找到规律,发现最多4次一个循环

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{    int a,b,c[4]; 
  while(cin>>a>>b)  
  {     
      a=a%10;
      c[0]=a;//一次方的末尾数    
      c[1]=(c[0]*a)%10;//二次方的末尾数
      c[2]=(c[1]*a)%10;//三次方的末尾数
      c[3]=(c[2]*a)%10;//四次方的末尾数    
      if(b%4==1)        
          cout<<c[0]<<endl;
      if(b%4==2)    
          cout<<c[1]<<endl;
      if(b%4==3)         
          cout<<c[2]<<endl;
      if(b%4==0)         
          cout<<c[3]<<endl; 
  }    
  return 0;
}
上一篇 下一篇

猜你喜欢

热点阅读