PAT甲级JAVA版 1002 A+B for Polynomi

2019-01-29  本文已影响0人  杨小码

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K\ N _{1}a_{N_{1}}\ N _{2}a_{N_{2}}\ ...\ N _{K}a_{N_{K}}
where K is the number of nonzero terms in the polynomial, N_{i} and a_{N_{i}}(i =1,2,...,k) are the exponents and coefficients, respectively. It is given that 1\le K \le10,0\le N_{K}<...<N_{2}<N_{1} \le 1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

1002 多项式 A + B (25 分)

这一次,你应该找到A+B,其中A和B是两个多项式。

输入规格

每个输入文件包含一个测试用例。每个案例占2行,每一行包含一个多项式的信息:​K\ N _{1}a_{N_{1}}\ N _{2}a_{N_{2}}\ ...\ N _{K}a_{N_{K}}其中K是多项式中的非零项数,N_{i} and a_{N_{i}}(i=1,2,…,k)分别是指数和系数。它被限制为1\le K \le10,0\le N_{K}<...<N_{2}<N_{1} \le 1000.

输出规格

对于每个测试用例,您应该在一行中输出A和B的和,其格式与输入相同。请注意,每一行的末尾必须没有额外的空间。请精确到小数点后1位。

输入样例

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出样例

3 2 1.5 1 2.9 0 3.2

代码

import java.util.Scanner;

public class Main {
    private static Scanner sc;
    public static void main(String[] args) {
        // TODO Auto-generated method stub
        float[] arr = new float[1001];
        int a = 0;
        int b = 0;
        int c = 0;
        int tem;
        sc = new Scanner(System.in);
        a = sc.nextInt();
        for (int i = 0; i < a; i++) {
            tem = sc.nextInt();
            arr[tem] += sc.nextFloat();
        }
        b = sc.nextInt();
        for (int i = 0; i < b; i++) {
            tem = sc.nextInt();
            arr[tem] += sc.nextFloat();
        }
        sc.close();
        for (int i = 0; i < 1001; i++) {
            if (arr[i] != 0) {
                c++;
            }
        }
        System.out.print(c);
        for (int i = 1000; i >=0; i--) {
            if (arr[i] != 0.0) {
                System.out.format(" %d %.1f", i,arr[i]);
                //System.out.print(" " + i + " " + arr[i]);
            }
        }
    }
}
上一篇下一篇

猜你喜欢

热点阅读