【PAT-甲级-C++】1008. Elevator (20)

2018-01-23  本文已影响18人  linghugoogle

1008. Elevator (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

1、题目

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41

2、注意

3、代码

#include<iostream>
#define N 101
using namespace std;
int main() {
    int n, a[N];
    int i, j;
    int total_time = 0;
    //读入数据
    cin >> n;
    //从0层开始
    a[0] = 0;
    for (i = 1;i <= n;++i) {
        cin >> a[i];
    }
    //计算时间
    //停留时间
    total_time += n * 5;
    //上行、下行时间
    for (i = 0;i < n;++i) {
        if (a[i+1]>a[i])
            total_time += (a[i + 1] - a[i]) * 6;
        else total_time += (a[i] - a[i+1]) * 4;
    }
    cout << total_time << endl;
    system("pause");
    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读