A_1001

2018-07-22  本文已影响0人  isjinhao

1001 A+B Format (20)
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

注意:当和为0时需要输出0!
#include <bits/stdc++.h>
using namespace std;
int main()
{
    int a, b, sum, cnt = 0;
    char str[101];
    cin >> a >> b;
    sum = a + b;
    if(sum == 0)
        cout << 0;
    if(sum < 0){
        cout << '-';
        sum = -sum;
    }
    while(sum != 0){
        str[cnt++] = char(sum%10 + 48);
        sum /= 10;
    }
    for(int i = cnt - 1; i >= 0; i--){
        cout << str[i];
        if(i%3 == 0 && i != 0)
            cout << ","; 
    }
    return 0;
} 
上一篇下一篇

猜你喜欢

热点阅读