【MAC 上学习 C++】Day 50-4. 实验8-2-4 使

2019-10-13  本文已影响0人  RaRasa

实验8-2-4 使用函数实现字符串部分复制 (20 分)

1. 题目摘自

https://pintia.cn/problem-sets/13/problems/552

2. 题目内容

本题要求编写函数,将输入字符串t中从第m个字符开始的全部字符复制到字符串s中。

函数接口定义:

void strmcpy( char *t, int m, char *s );
函数strmcpy将输入字符串char *t中从第m个字符开始的全部字符复制到字符串char *s中。若m超过输入字符串的长度,则结果字符串应为空串。

输入样例:

7
happy new year

输出样例:

new year

3. 源码参考
#include <iostream>

using namespace std;

#define MAXN 20

void strmcpy( char *t, int m, char *s );
void ReadString( char s[] ); 

int main()
{
    char t[MAXN], s[MAXN];
    int m;

    cin >> m;
    cin.ignore(numeric_limits<std::streamsize>::max(),'\n'); //清除缓冲区的当前行
    ReadString(t);
    strmcpy( t, m, s );
    cout << s << endl;

    return 0;
}

void strmcpy( char *t, int m, char *s )
{
  int i, n;

  n = strlen(t);
  for(i = 0; i <= n - m; i++)
  {
    s[i] = t[i + m - 1];
  }

  return;
}

void ReadString( char s[] )
{
  cin.get(s, MAXN, '\n');
  return;
}
上一篇下一篇

猜你喜欢

热点阅读