2020-04-15

2020-04-15  本文已影响0人  joker_luo

1074 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

      
    

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

      
    

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
#include<iostream>
using namespace std;
int main(){
    int adr[100010],data[100010],next[100010],result[100010];
    int begin,n,k;
    int sum = 0;
    cin>>begin>>n>>k;
    int address;
    for(int i=0;i<n;++i){
        cin>>address;
        cin>>data[address]>>next[address];
    }
    while(begin!=-1){
        adr[sum++] = begin;
        begin = next[begin];
    }
    for(int i=0;i<sum;++i){
        result[i] = adr[i];//以地址的形式保存链表 
    }
    for(int i=0;i<(sum - sum%k);++i){
        //1.i/k确定分组2.乘k定位到第i组对应的第一个元素index 3.-1-i%k是减去数组下标多的一位以及不参与逆置的元素
        //最终result保存的是逆置后的address 
        result[i] = adr[i/k*k+k-1-i%k];
    }
    for(int i=0;i<sum-1;++i){
        printf("%05d %d %05d\n",result[i],data[result[i]],result[i+1]);
    }
    printf("%05d %d -1\n",result[sum-1],data[result[sum - 1]]);
    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读