1041 Be Unique(20 分)

2018-08-29  本文已影响0人  W杂货铺W

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

超时版本

#include <iostream>
#include <vector>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int v[100001];
    int flag;
    for(int i=0;i<n;i++)
    {
        cin >> v[i];
    }
    for(int j=0;j<n;j++)
    {
        flag = 0;
        for(int k=j+1;k<n;k++)
        {
            if(v[k]==v[j]) {
                flag = 1;
                break;
            }
        }
        for(int m = 0;m<j;m++){
            if(v[m]==v[j]) {
                flag = 1;
                break;
            }
        }
        if(flag==0) {
            cout << v[j];
            break;
        }
    }
    if(flag==1) cout << "None";
    return 0;
}

正确版本

#include <iostream>
#include <vector>
using namespace std;
int main()
{
    int v[100001],cnt[10001];
    int n;
    cin >> n;
    for(int i=0;i<n;i++)
    {
        cin >> v[i];
        cnt[v[i]]++;
    }
    for(int i=0;i<n;i++)
    {
        if(cnt[v[i]]==1) {
            cout << v[i];
            return 0;
        }
    }
    cout << "None";
    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读