PAT Basic 1081. 检查密码 (15)(C语言实现)

2018-03-25  本文已影响160人  OliverLew

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点
.,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N( \le 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

思路

没有什么难度,确定好哪种情况优先级高就行了。优先级依次为:

  1. 密码太短
  2. 存在不合法字符
  3. 缺少数字或者字母

想吐槽的就是题目不很严谨啊,全是小数点就合法了吗?

代码

最新代码@github,欢迎交流

#include <stdio.h>
#include <ctype.h>

int main()
{
    char c;
    int N, count, num_digit, num_alpha, num_else;

    scanf("%d", &N);
    while(getchar() == '\n');
    for(int i = 0; i < N; i++)
    {
        num_digit = num_alpha = num_else = 0;
        for(count = 0; (c = getchar()) != '\n'; count++)
        {
            if(isdigit(c))      num_digit++;
            else if(isalpha(c)) num_alpha++;
            else if(c != '.')   num_else++;
        }
        if(count < 6)                    puts("Your password is tai duan le.");
        else if(num_else)                puts("Your password is tai luan le.");
        else if(num_alpha && !num_digit) puts("Your password needs shu zi.");
        else if(num_digit && !num_alpha) puts("Your password needs zi mu.");
        else                             puts("Your password is wan mei.");
    }

    return 0;
}
上一篇下一篇

猜你喜欢

热点阅读