【MAC 上学习 C++】Day 53-5. 实验11-1-2
2019-10-16 本文已影响0人
RaRasa
实验11-1-2 输出月份英文名 (15 分)
1. 题目摘自
https://pintia.cn/problem-sets/13/problems/589
2. 题目内容
本题要求实现函数,可以返回一个给定月份的英文名称。
函数接口定义:
char *getmonth( int n );
函数getmonth应返回存储了n对应的月份英文名称的字符串头指针。如果传入的参数n不是一个代表月份的数字,则返回空指针NULL。
输入样例1:
5
输出样例1:
May
输入样例2:
15
输出样例2:
wrong input!
3. 源码参考
#include <iostream>
using namespace std;
char *getmonth( int n );
int main()
{
int n;
char *s;
cin >> n;
s = getmonth(n);
if ( s==NULL )
{
cout << "wrong input!" << endl;
}
else
{
cout << s << endl;
}
return 0;
}
char *getmonth(int n)
{
if((n >= 1) && (n <= 12))
{
const char *m[12] = { "January","February","March","April","May","June","July","August","September","October","November","December" };
return (char*)m[n - 1];
}
else
{
return NULL;
}
}