1085 Perfect Sequence(排序)
1085 Perfect Sequence (25 分)
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105 ) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109 .
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
题目大意
给定一个序列A和参数p,若序列A中最大值为M,最小值为m,满足M<=m*p,则称序列A为perfect sequence;依据这个定义,题目要求在给定的序列中找出尽可能多的元素组成一个新的序列,使得这个序列为perfect sequence。
分析
寻找序列极值问题,若对算法的复杂度无苛刻要求,可先对序列排序,定义当前最大宽度maxwidth,遍历序列,遍历过程中以当前maxwidth为起始宽度寻找比maxwidth更大宽度的序列。另外,题目中序列元素和参数p的范围均为0~109,两数想成数的范围将可能超过109,因此将数的类型定义为long int
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> v;
int main(){
long long n,p;
cin>>n>>p;
v.resize(n);
for(int i=0;i<n;i++) cin>>v[i];
sort(v.begin(), v.end());
int maxwidth=1;
for(int i=0;i<n;i++){
while(i+maxwidth-1<n && v[i+maxwidth-1]<=p*v[i]) maxwidth++;
}
cout<<maxwidth-1;
}