杭电acm1232 畅通工程

2018-06-28  本文已影响0人  cwhong

畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 59587 Accepted Submission(s): 31854

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 
Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 
Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 
Sample Input
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 
Sample Output
1 0 2
998

Solution

这是一个最小生成树和并查集问题,先使用并查集处理随后在查看有多少未联通的城镇即有多少点的根结点为其本身

Code

/**
 * date:2017.11.20
 * author:孟小德
 * function:杭电acm1232
 *      畅通工程    使用查并集方法
 */
 
 
 
import java.util.*;
 
public class acm1232
{
    public static int[] father;
 
    public static void main(String[] args)
    {
        Scanner input = new Scanner(System.in);
 
        int N,M;
        int result;
 
 
        while (input.hasNextInt())
        {
            N = input.nextInt();
            if (N == 0)
            {
                break;
            }
            M = input.nextInt();
            father = new int[N+1];
            for (int i=1;i<N+1;i++)
            {
                father[i] = i;
            }
 
            for (int i=0;i<M;i++)
            {
                int a = input.nextInt();
                int b = input.nextInt();
                union(a,b);
 
            }
 
            result = 0;
            //若该树是联通的,那么只有一个节点的父节点是其自身
            for (int i=1;i<N+1;i++)
            {
                if (father[i] == i)
                {
                    result++;
                }
            }
 
            System.out.println(result - 1);
 
        }
 
    }
    public static void union(int m,int n)
    {
        //合并集合
        int a = getParent(m);
        int b = getParent(n);
 
        if (a!=b)
        {
            father[a] = b;
        }
 
    }
 
    public static int getParent(int m)
    {
        //寻找节点的根节点
        while (father[m] != m)
        {
            m = father[m];
        }
        return m;
    }
 
}

上一篇下一篇

猜你喜欢

热点阅读