HDU 1250 Hat's Fibonacci

2022-04-02  本文已影响0人  itbird01

Problem Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input
Each line will contain an integers. Process to end of file.

Output
For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

Author
戴帽子的

import java.math.BigDecimal;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        while (cin.hasNextInt()) {
            int n = cin.nextInt();
            BigDecimal f1 = new BigDecimal("1");
            BigDecimal f2 = new BigDecimal("1");
            BigDecimal f3 = new BigDecimal("1");
            BigDecimal f4 = new BigDecimal("1");
            if (n == 1 || n == 2 || n == 3 || n == 4) {
                System.out.println(f4.stripTrailingZeros().toPlainString());
            } else {
                for (int i = 5; i <= n; i++) {
                    BigDecimal temp = f4;
                    f4 = f1.add(f2).add(f3).add(f4);
                    f1 = f2;
                    f2 = f3;
                    f3 = temp;
                }
                System.out.println(f4.stripTrailingZeros().toPlainString());
            }
        }
        cin.close();
    }

}```
上一篇下一篇

猜你喜欢

热点阅读