PAT (Basic Level):1044 火星数字(20)

2018-06-20  本文已影响0人  沙_狸

题目信息

火星人是以13进制计数的:
地球人的0被火星人称为tret。
地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13

代码

#include<iostream>
using namespace std;
void change(string s){
    int i,c=0,earth_num=0;
    string temp;
    string low[13]={"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"}; 
    string high[12]={"tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};
    if(s[0]-'0'>=0&&s[0]-'0'<10){//如果是地球数字 
            for(int j=0;j<s.length();j++) earth_num=earth_num*10+s[j]-'0';//将字符串转成十进制数字
            if(earth_num==0) cout<<"tret"; 
            else if(earth_num<13) cout<<low[earth_num]<<endl;
            else if(earth_num%13==0) cout<<high[earth_num/13-1]<<endl;
            else cout<<high[(earth_num/13)%13-1]<<" "<<low[earth_num%13]<<endl;
        }else{//如果是火星数字
            if(s.length()==3){
                for(int i=1;i<13;i++){
                    if(s.substr(0,3)==low[i]) cout<<i<<endl;
                }
                for(int i=0;i<12;i++){
                    if(s.substr(0,3)==high[i]) cout<<13*(i+1)<<endl;
                }
            }else if(s.length()==7){
                for(int i=0;i<12;i++){
                    if(s.substr(0,3)==high[i]) earth_num+=i+1;
                }
                for(int i=1;i<13;i++){
                    if(s.substr(4,3)==low[i]) cout<<earth_num*13+i<<endl;
                }
            }else{
                cout<<0<<endl;
            }   
        }
}
int main(){
    int n;string s;
    scanf("%d\n",&n);
    for(int i=0;i<n;i++){
        getline(cin,s);
        change(s);
    }
    return 0;
} 

测试结果

image.png
上一篇下一篇

猜你喜欢

热点阅读