PAT 甲级 刷题日记|A 1053 Path of Equal

2021-08-07  本文已影响0人  九除以三还是三哦

题目

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

1628304080424.png

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
结尾无空行

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
结尾无空行

思路

这道题考察的是建树+ DFS 遍历树。涉及到的并非二叉树,而是一般树。此处的难点在于深度优先遍历,递归过程中要保存什么样的值,递归的结束条件以及适当的剪枝。

在本题中,递归过程要保存当前节点,路径内容,以及加权和。

题目要求输出序列应该是非增序,借鉴晴神的处理方法,为输入时对child向量进行处理,进行排序,这样遍历过程中会优先遍历大值,这样输出的结果自然是非增序了。

代码

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1000;
int weights[maxn];
int path[maxn];
int N, M, S;

struct node{
    int weights;
    vector<int> child;
}Node[1000]; 

bool cmp(int a, int b) {
    return Node[a].weights > Node[b].weights;
}

void DFS(int index, int numNode, int sum) {
    if (sum > S) return;
    if (sum == S) {
        if (!Node[index].child.empty()) return;
        for (int i = 0; i < numNode - 1; i++) {
            cout<<Node[path[i]].weights<<" ";
        }
        cout<<Node[path[numNode - 1]].weights<<endl;
        return ;
    }
    for (int i = 0; i < Node[index].child.size(); i++) {
        int now = Node[index].child[i];
        path[numNode] = now;
        DFS(now, numNode + 1, sum + Node[now].weights);
    }
}

int main () {
    cin>>N>>M>>S;
    for (int i = 0; i < N; i++) {
        cin>>Node[i].weights;
    }
    int id, len;
    for (int i = 0; i < M; i++) {
        cin>>id>>len;
        int ch;
        for (int j = 0; j < len; j++) {
            cin>>ch;
            Node[id].child.push_back(ch);
        }
        sort(Node[id].child.begin(), Node[id].child.end(), cmp);
    }
    path[0] = 0;
    DFS(0, 1, Node[0].weights);
}
上一篇下一篇

猜你喜欢

热点阅读