1001 A+B Format (20)(20 分)

2018-08-20  本文已影响0人  W杂货铺W

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

code

#include <iostream>
int main(){
    int v1, v2, sum, x;
    int re[15];
    int i = 0;
    std::cin >> v1 >> v2;
    sum = v1 + v2;
    if(sum < 0) {
        std::cout << "-";
        sum = -sum;
    }
    do{
        x = sum % 10;
        sum = sum / 10;
        re[i] = x;
        i++;
    }while(sum != 0);
    std::cout << re[i-1];
    i--;
    while(i >= 1){
        if (i % 3 == 0) {
            std::cout << ',' << re[i-1];
        } else {
            std::cout << re[i-1];
        }
        i--;
    }
}
上一篇下一篇

猜你喜欢

热点阅读